How to Install Power Manager Over the Network

We step through installing Power Manager on a remote Mac over the network.

Installing Power Manager on remote Macs is possible, even without special network administration software. In this recipe we show how to install Power Manager using Mac OS X’s built-in tools ssh and installer.

If you are deploying Power Manager over large numbers of Macs, consider using a specialised tool such as Apple Remote Desktop (ARD) or radmin. Most seasoned tools support mass package deployment.

The method we are looking at today is ideal for home and small office networks where justifying the cost of additional tools is difficult.

Built-in Tools

We are going to use these command line tools to perform the installation:

  • curl
  • scp
  • ssh
  • installer

You will need ssh, secure shell, access to the target Mac and you will need administrator access on the target Mac.

Download Locally

Power Manager is available as a packaged installer designed for network deployment. The self-contained single package contains everything needed to set up Power Manager.

Screenshot showing Power Manager’s packaged installer

Download and mount the package volume with these two Terminal.app commands:

curl -L https://www.dssw.co.uk/powermanager/dsswpowermanagerpkg.dmg > /tmp/dsswpowermanagerpkg.dmg
hdiutil attach /tmp/dsswpowermanagerpkg.dmg

These two commands will download the latest Power Manager package from our web site and mount the volume.

Copy to Target

Securely copy the Power Manager package to the target Mac. Replace the target Mac’s address as needed; in this example, the remote user and address is admin@192.168.0.2:

scp '/Volumes/DssW Power Manager Pkg/DssW Power Manager.pkg' admin@192.168.0.2:/tmp/.

The installer package is now copied onto the target Mac ready for installation. We are finished with the local copy and can now unmount the volume:

hdiutil unmount '/Volumes/DssW Power Manager Pkg'

Install on Target

Securely connect to the target Mac and install the package:

ssh admin@192.168.0.2
sudo installer -package '/tmp/DssW Power Manager.pkg' -target /

With the installation complete, Power Manager is now installed but not yet running on the target Mac.

The best option is to restart the target Mac - or wait until the Mac is next restarted. On powering on, Power Manager will automatically start and be ready to use.

Avoiding the Restart

You can avoid restarting the target Mac. Any active users will need to log-out and log back in to see Power Manager’s notifications.

On the target Mac, we need to manually start Power Manager’s daemon process pmd. We do this via launchctl:

ssh admin@192.168.0.2
sudo launchctl load /Library/LaunchDaemons/uk.co.dssw.pmd.plist 

A few seconds after issuing the launchctl command, Power Manager will be available on your target Mac.

Variations

There are many ways to combine these installation commands. If your network connection to the target Mac is slow, you may wish to perform the download on the target Mac:

ssh admin@192.168.0.2
curl -L https://www.dssw.co.uk/powermanager/dsswpowermanagerpkg.dmg > /tmp/dsswpowermanagerpkg.dmg
hdiutil attach /tmp/dsswpowermanagerpkg.dmg
sudo installer -package '/Volumes/DssW Power Manager Pkg/DssW Power Manager.pkg' -target /
hdiutil unmount '/Volumes/DssW Power Manager Pkg'