Power Manager 4.6.5 Released

We are pleased to announce the launch of Power Manager 4.6.5. This update focuses on code modernisation and deprecates a few older security options.

Power Manager 4.6.5 requires macOS 10.10 or later.

Updating Power Manager

Power Manager will automatically check for updates every so often, so there is nothing to do. The update will automatically be offered to you during the next few weeks.

If you want to update to the latest Power Manager now, use the Check for Updates… menu item in the Power Manager menu.

Screenshot showing the Check for Updates menu item in Power Manager

For Power Manager Professional, use the following menu item: Power Manager > Check for Updates….

Changes in v4.6.5

  • Change: Updated AstronomicalAlgorithms framework.
  • Change: Updated CodeMirror library.
  • Change: Updated LetsMove library.
  • Change: Updated Sparkle framework.
  • Change: Continued modernisation of code.
  • Bug: Fixed immediate removal of temporary file.
  • API: Deprecated launch behaviour untrusted.
  • API: Deprecated process entry process information.
  • API: Deprecated SSL/TLS protocols SSLv2 and SSLv3.

A detailed version history of Power Manager is also available.

This article was posted in , , and and tagged .

Published by Graham Miln on